OpenInvoice Service Disruption

Incident Report for Enverus Business Automation

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 11:34 MDT

Update

We are continuing to investigate this issue.
Posted Mar 16, 2026 - 11:04 MDT

Investigating

We have received reports of performance and application issues impacting some users and integration traffic. We are actively investigating these issues and are working towards a resolution.

If you have any questions, comments, or concerns regarding this notification please contact our support team by email at openinvoicesupport@enverus.com.
Posted Mar 16, 2026 - 10:27 MDT
This incident affected: OpenInvoice for Suppliers (OpenInvoice Portal, OpenInvoice Integration/APIs, OpenInvoice SupplierLink), OpenTicket for Buyers (OpenTicket Portal, OpenTicket Integration/APIs), OpenTicket for Suppliers (OpenTicket Portal, OpenTicket Integration/APIs), RFx (RFx), OFS Directory (OFS Directory), and OpenInvoice for Buyers (OpenInvoice Portal, OpenInvoice Integration/APIs).