OpenInvoice Service Disruption

Incident Report for Enverus Business Automation

Resolved

The Enverus technical team has restored service to the OpenInvoice production environment. We will continue to monitor the environment and will make our Root Cause Analysis available upon request once it is available.
Posted Jul 29, 2026 - 11:19 MDT

Investigating

We're currently experiencing a system performance issue that may impact your ability to access or use OpenInvoice. Our team is actively investigating the issue and working to restore normal service as quickly as possible. We appreciate your patience.
Posted Jul 29, 2026 - 11:09 MDT
This incident affected: OpenInvoice for Suppliers (OpenInvoice Portal, OpenInvoice Integration/APIs, OpenInvoice SupplierLink), OpenTicket for Buyers (OpenTicket Portal, OpenTicket Integration/APIs), OpenTicket for Suppliers (OpenTicket Portal, OpenTicket Integration/APIs), and OpenInvoice for Buyers (OpenInvoice Portal, OpenInvoice Integration/APIs).