Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 29, 2025 - 18:00 MDT
Scheduled
We will be conducting infrastructure maintenance this weekend. While the maintenance is in progress, the OpenInvoice production environment, including OpenInvoice SupplierLink, will be unavailable for approximately 12 hours starting at 6:00 pm MT on Friday, August 29th.
During the scheduled infrastructure maintenance, users may experience reduced functionality across multiple systems. This includes limited capabilities within the Oilfield Services Suite (OSS) when managing tickets for OpenTicket customers. RFx and the OFS Directory will also be impacted, with potential disruptions or reduced performance during this time.
If you have any questions, comments, or concerns regarding this notification please contact our support team by email at openinvoicesupport@enverus.com.
Posted Aug 27, 2025 - 09:56 MDT
This scheduled maintenance affected: OpenInvoice for Suppliers (OpenInvoice Portal, OpenInvoice Integration/APIs, OpenInvoice SupplierLink), OpenTicket for Buyers (OpenTicket Portal, OpenTicket Integration/APIs), OpenTicket for Suppliers (OpenTicket Portal, OpenTicket Integration/APIs), and OpenInvoice for Buyers (OpenInvoice Portal, OpenInvoice Integration/APIs).